
ADIO-EC (TwinCAT 3 Guide)
User Manual     MTO-ADIOECU1-V1.0-2202US





Contents

Preface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  7

Manual Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9

Common Symbols in the Manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11

1. ADIO-EC (TwinCAT 3 Guide). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

1.1. Prepare Your Environment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

1.1.1. Install ESI File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

1.1.2. Install the Ethernet Adapter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

1.2. Integrate IO-Link Master to TwinCAT Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

1.2.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

1.2.2. Create a New Project. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

1.2.3. Main Screen on the EtherCAT Slave . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

1.2.4. Add EtherCAT Slave . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  18

1.2.5. Apply to the EtherCAT Slave . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21

1.2.6. Integrate the ADIO-EC to the PLC Project . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  22

2. Monitor the Port Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25

2.1. Definition of the Online Values. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26

3. Check the Address of the ADIO-EC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29

3.1. EtherCAT Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29

4. Configure the I/O Port. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  31

4.1. Slots Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  31

4.2. List of Slots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32

4.3. List of Modules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  33

4.4. Mapping: Modules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  33

5. Assign the Modules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

5.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

5.2. Assigning a Module. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

6. Monitor the Module Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

6.1. STD_IN_1bit / STD_OUT_1bit. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

6.2. INPUT_PIN2_8CH / INPUT_PIN4_8CH . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41

6.3. ACTOR_SHORTCIRCUIT_PIN4_8CH. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  43

6.4. SENSOR_SUPPLY_SHORTCIRCUIT_8CH . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44



6.5. MODULE_STATUS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

6.6. OUTPUT_PIN4_8CH . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  46

7. Process Data Object (PDO) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  47

7.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  47

7.2. Check the TxPDO. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48

7.3. Write the RxPDO . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49

8. Access ISDU Parameters. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51

8.1. CoE-Online Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51

8.2. Read and Write the Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53

8.3. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53

8.4. Read the Parameter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  54

8.5. Write the Parameter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55

8.6. Check the Changed Parameter. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  56

9. Startup Tab. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57

9.1. Supported Functions on the Startup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  59

9.2. Input Filter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  59

9.2.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  59

9.2.2. Select Input Filtering Time . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  60

9.3. Safe State . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63

9.3.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63

9.3.2. Setting Safe State. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  64

9.4. Validation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66

9.4.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66

9.4.2. Setting Validation Type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  67

9.5. Data Storage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

9.5.1. Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

9.5.2. Setting Data Storage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  70

10. Replace the IO-Link Device . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  75

11. Object List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77

11.1. Process Data (Pin 2) Ch. X . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77

11.2. Process Data (Pin 4) Ch. X . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77

11.3. Additional IO-Link Configuration Data (Pin 4) Ch. X . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  78

11.4. Module Status Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  78

11.5. IO-Link Service Data Ch. x . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  79



11.6. IO-Link Configuration Data Ch. x . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  79

11.7. IO-Link Information Data Ch. x. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80

11.8. IO-Link Diagnosis Data Ch. x. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80

11.9. IO-Link Status Data Ch. x . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80





Preface

Thank you for purchasing Autonics products.
Be sure to read and follow the Safety Precautions thoroughly before use.
This manual contains information about the product and how to use it properly, so keep it in a place
where users can easily find it.

Preface 　 7
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Manual Guide

• Use the product after fully reading the contents of the manual.

• The manual explains the product functions in detail and does not guarantee the contents other than
the manual.

• Any or all of the manual may not be edited or copied without permission.

• The manual is not provided with the product.

• Download and use from our website (www.autonics.com).

• The contents of the manual are subject to change without prior notice according to the improvement
of the product’s performance, and upgrade notices are provided through our website.

• We put a lot of effort to make the contents of the manual a little easier and more accurate.
Nevertheless, if you have any corrections or questions, please feel free to comment through our
website.

Manual Guide 　 9
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Common Symbols in the Manual

Failure to follow instructions may result in serious injury or death.

Failure to follow instructions may result in injury or product damage.

Supplementary explanation of the function

Example of that function

Important information about the feature

Common Symbols in the Manual 　 11
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1. ADIO-EC (TwinCAT 3 Guide)

Be sure to see the product manual of the ADIO-EC (EtherCAT) model and follow the
precautions.

1.1. Prepare Your Environment

1.1.1. Install ESI File
1. Download the ADIO-EC’s ESI file on the Autonics website. The structure of the ESI file is as below.

◦ ADIO-EC_v1.x

◦ ADIO-EC_Modules_v1.x

2. Copy the downloaded file to the following subdirectory of the TwinCAT installation directory.
The path of the folder: ~\TwinCAT\3.1\Config\Io\EtherCAT

3. Launch the TwinCAT 3.

• The EtherCAT Slave Information (ESI) file describes specific data of the EtherCAT
Slave, and defines the parameters, process data, valid values and more.
The EtherCAT Master recognizes the Slave and obtains the necessary information
for control via the ESI file.

• To integrate the ESI file when the project file is running in the TwinCAT 3,
select the TwinCAT » EtherCAT Devices » Reload Device Descriptions on the top
menu.

1.1. Prepare Your Environment 　 13



1.1.2. Install the Ethernet Adapter
1. Connect the cable connected to the Ethernet port of the ADIO-EC to the port of the device that the

TwinCAT is installed.

2. Launch the TwinCAT 3.

3. Select the TwinCAT » Show Realtime Ethernet Compatible Device on the top menu.

14 　 Autonics | ADIO-EC (TwinCAT 3 Guide)



4. Select the LAN card that is connected with the ADIO-EC in the sub-list of the Compatible devices,
and then select Install . Selecting a device in the sub-list of the Incompatible devices does not
guarantee a successful installation.

5. Check that the LAN card is located to the sub-list of the Installed and Ready to use devices (realtime
capable). The installation of LAN card is complete.

1.1. Prepare Your Environment 　 15



1.2. Integrate IO-Link Master to TwinCAT Project
This chapter explains how to integrate the ADIO-EC to the project as an EtherCAT Slave.

1.2.1. Before You Begin
• The ESI file of the ADIO-EC is already installed.

1.2.2. Create a New Project
1. Launch the TwinCAT 3.

2. On the Start Page, select New TwinCAT project…

3. In pop-up window, select TwinCAT XAE Project (XML format). Enter a project name and select OK .
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1.2.3. Main Screen on the EtherCAT Slave

① Solution Explorer

It shows the EtherCAT Slave as the tree structure.
You can see the port configuration and status of the ADIO-EC, selecting the menu to go to the each
tab of the Editor Window.

② Editor Window

The tab of the Editor Window shows the configuration of the EtherCAT Slave and the functions can
be configured. Select Solution Explorer » Box 1 (ADIO-EC) to go to the tab.
For more information, see the following chapters.

• EtherCAT

• Slots

• Startup

• CoE-Online

③ Port Status Viewer

You can monitor the status of each I/O port via the value of Online.
You can also monitor it in the Solution Explorer » IO-Link DeviceState Inputs.

1.2. Integrate IO-Link Master to TwinCAT Project 　 17



1.2.4. Add EtherCAT Slave

The number after Device/Box in the figure below may vary depending on the
installation environment.

1. Right-click on the Solution Explorer » Devices.

2. Select Scan .

3. In pop-up window, confirm the checkbox of the Device 2 (EtherCAT) and select OK .
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4. Check Solution Explorer » Box 1 (ADIO-EC).
Device and Box shown in the Solution Explorer are defined as below.

◦ Device 2 (EtherCAT): EtherCAT Master

◦ Box 1 (ADIO-EC): EtherCAT Slave

Box no. (ADIO-EC) does not appear in the Solution Explorer,
check the power supply of the ADIO-EC and the status of EtherCAT
communication cable.

1.2. Integrate IO-Link Master to TwinCAT Project 　 19



5. Double-click the Solution Explorer » Box 1 (ADIO-EC).

6. Check the Online Data in the Editor Window » CoE-Online tab.

7. Check the list of slots and modules in the Editor Window » Slots tab.
For detailed information on the configuration of slots and modules, refer to  4, Configure the I/O Port.

8. The ADIO-EC has been successfully added.
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1.2.5. Apply to the EtherCAT Slave
When a change occurs in the configuration of acyclic data in the TwinCAT project,
follow the procedure below for applying to the EtherCAT Slave.

1. Select  (Restart TwinCAT) or  (Reload Device) on the top menu.

2. Select OK  in pop-up window.

3. The changes have been applied to the ADIO-EC.

• Cyclic data:
It is the process data objects (PDO) which is related to the input and output data of
the IO-Link device.

• Acyclic data:
It is the vendor specific object lists such as the data of port configuration
information and diagnostics.

1.2. Integrate IO-Link Master to TwinCAT Project 　 21



1.2.6. Integrate the ADIO-EC to the PLC Project
1. Select the Solution Explorer » PLC » Add New item.

2. In pop-up window, select the Standard PLC Project. Enter a project name and select Add .
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3. MAIN (PRG) is created by default in the sub-list of the Solution Explorer » POUs.
MAIN (PRG) only supports ST language.

4. Right-click on the Solution Explorer » PLC » POUs and select Add » POU….

1.2. Integrate IO-Link Master to TwinCAT Project 　 23



5. In pop-up window, Enter a Name, Type, and Language and select Open .

6. The screen of TwinCAT Ladder program appears.
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2. Monitor the Port Status

1. Select the Solution Explorer » Box 1 (ADIO-EC) » IO-Link DeviceState Inputs.

2. Check the value on the Online tab in the Editor Window.
For detailed information on the port status, refer to the mapping of  11.9, “IO-Link Status Data Ch. x”.

2. Monitor the Port Status 　 25



2.1. Definition of the Online Values
Hex Dec Description

0x_0 0 Port disabled

0x_1 1 Port in std dig in

0x_2 2 Port in std dig out

0x_3 3 Port in communication OP

0x_4 4 Port in communication COMSTOP

0x1_ 16 Watchdog detected

0x2_ 32 initial Error

0x3_ 48 invalid DID

0x4_ 64 invalid VID

0x5_ 80 invalid IO-Link Version

0x6_ 96 invalid Frame Capability

0x7_ 112 invalid Cycle Time

0x8_ 128 invalid PD in length

0x9_ 144 invalid PD out length

0xA_ 160 no device detected
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Setting the Display Mode

1. Select the Solution Explorer » Box 1 (ADIO-EC) » IO-Link DeviceState Inputs » Status of IO-Link
Port x.

2. Select the display format of the Online values among Dec, Hex, and Both in the Display Mode of the
Flags tab.

◦ Dec: Decimal format

◦ Hex: Hexadecimal format

◦ Both: Decimal (hexadecimal) format

2.1. Definition of the Online Values 　 27
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3. Check the Address of the ADIO-EC

3.1. EtherCAT Tab

Type

It shows the device type of the EtherCAT Slave.

Product/Revision

It shows the product and revision number of the EtherCAT Slave.
"19" is the product number of the ADIO-EC and "2" is the revision number.

3.1. EtherCAT Tab 　 29



Auto Inc Addr

It contains the auto-increment address of the EtherCAT Slave. It is assigned by the EtherCAT Master.
In the ring topology, the address is assigned in the form of decreasing the value by 1, such as the
address of the first EtherCAT Slave: 0x0000, the second device: 0xFFFF, the third device: 0xFFFE…

EtherCAT Addr

It contains the communication address of the EtherCAT Slave. It is assigned by the EtherCAT Master
in the same as with the Auto Inc Addr. If the checkbox on the left side is selected, the EtherCAT
address of the slave device does not change even if another device (Box) is added to the ring network
(the fixed address). You can also change the assigned address value.
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4. Configure the I/O Port

4.1. Slots Tab
The I/O ports on the ADIO-EC, as a modular device, can be configured by assigning the (physical)
modules to the slots.
In the figure below, the list of slots on the left side acts as a placeholder to find the modules on the
right side. The modules on the right side are defined by the ModuleIdent The ModuleIdent varies
depending on the manufacturers and identifies a specific module.

4.1. Slots Tab 　 31



4.2. List of Slots
Slot no. Slot Description

1 to 8 IO-Link Ch.0 to 7 Configure the operation mode (IO-Link/DI/DO) and the process
data length on each I/O port

9 Input Pin 2 Create an address that can read the input value of Pin 2

10 Input Pin 4 Create an address that can read the input value of Pin 4

11 Short Circuit Pin 4 Create an address that can read the short circuit status of Pin 4

12 Sensor Short Circuit Create an address that can read the short circuit status of the
connected sensor

13 Module status Create an address that can read the status of each I/O port

14 Output Pin 4 Create an address to set the output value of Pin 4
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4.3. List of Modules
Module Description

STD_IN_1bit Configuration of Pin 4: Standard Input

STD_OUT_1bit Configuration of Pin 4: Standard Output

IOL_I/O_x/_xbyte Configuration of the port: Select the size (byte) of the IO-Link
input and output data
(1) I/O
• I: data input
• O: data output
• I/O: data input and output
(2) x/_xbyte
• input byte/_output byte,
the size of process data

INPUT_PIN2_8CH Monitoring: Value of Pin 2 in the standard input mode

INPUT_PIN4_8CH Monitoring: Value of Pin 4 in the standard input mode

ACTOR_SHORTCIRCUIT_PIN4_8CH Monitoring: Short circuit of Pin 4

SENSOR_SUPPLY_SHORTCIRCUIT_8CH Monitoring: Short circuit of connected sensor (US)

MODULE_STATUS Monitoring: Port status
• Bit 0: US low
• Bit 1: UA low
• Bit 2: no UA

OUTPUT_PIN4_8CH Configuration of Pin 4: Output value of the standard output

4.4. Mapping: Modules
Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Port 7 Port 6 Port 5 Port 4 Port 3 Port 2 Port 1 Port 0

The corresponding modules

• INPUT_PIN2_8CH

• INPUT_PIN4_8CH

• ACTOR_SHORTCIRCUIT_PIN4_8CH

• SENSOR_SUPPLY_SHORTCIRCUIT_8CH

• OUTPUT_PIN4_8CH

4.3. List of Modules 　 33
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5. Assign the Modules

5.1. Before You Begin
• The ADIO-EC is integrated to the TwinCAT project.

5.2. Assigning a Module

1. Select the Solution Explorer » Device » Box 1 (ADIO-EC).

2. Select the Editor Window » Slots Tab.

3. Select the the slot you want to change in the left side.

4. Select the X  to delete the module.

5. Select a module to be assigned in the right side.

6. Select the <  to assign the module to the slot.

7. The module has been assigned to the slot.

5.1. Before You Begin 　 35



8. Repeat the procedure above to configure the I/O port. You can check the configuration of I/O port in
the Solution Explorer.

9. Save the project.

10. Select  (Restart TwinCAT) or  (Reload Device).

36 　 Autonics | ADIO-EC (TwinCAT 3 Guide)



• All modules assigned to the slots of IO-Link Ch.0 to Ch.7 must exist.
For unused I/O port, it is recommended to assign the STD_IN_1bit module (factory
settings).

• When assigning the OUTPUT_PIN4_8CH module, make sure that no module is
assigned to the slots of IO-Link Ch.0 to Ch.7.

5.2. Assigning a Module 　 37
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6. Monitor the Module Status

For more information on the IOL_I/O_x/_xbyte module,
refer to  7, Process Data Object (PDO).

6.1. STD_IN_1bit / STD_OUT_1bit
You can monitor the status of SIO (standard input and standard output) mode on each I/O port.
For PNP model of the ADIO-EC,
• 0x00 (0): Input and output signal of Pin 4 is Low
• 0x01 (1): Input and output signal of Pin 4 is High

Standard Input

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 1 (STD_IN_1bit) »
Digital Input Bit (sub-variable).

2. Check the value in the Editor Window » Online tab.
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Standard Output

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 2 (STD_OUT_1bit) »
Digital Output Bit (sub-variable).

2. Select the Editor Window » Online Tab.

3. Select the Write  to enter a value.
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6.2. INPUT_PIN2_8CH / INPUT_PIN4_8CH
Input pin 2/4: Read the digital input signal from Pin 2/4 on all I/O ports.
Pin 2 (I/Q) is fixed as the digital input mode.
For PNP model of the ADIO-EC,
• 0x00 (0): OFF the input signal to Pin 2 or 4
• 0x01 (1): ON the input signal to Pin 2 or 4

Input Pin 2

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 9 (INPUT_PIN2_8CH) »
IO Input Pin 2 (8 Ch).

2. Check the Online value in the Editor Window.
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Input Pin 4

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 10 (INPUT_PIN4_8CH)
» IO Input Pin 4 (8 Ch).

2. Check the Online value in the Editor Window.
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6.3. ACTOR_SHORTCIRCUIT_PIN4_8CH
If the short circuit occurs on Pin 4 of each I/O port,
the Online value of the corresponding port is changed to 1.
• 0x01 (1): Short circuit occurred on Pin 4

Actor short circuit Pin 4

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 11
(ACTOR_SHORTCIRCUIT_PIN4_8CH) » IO Actor short circuit Pin 4 (8 Ch).

2. Check the Online value in the Editor Window.
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6.4. SENSOR_SUPPLY_SHORTCIRCUIT_8CH
If the short circuit occurs on the I/O supply power (Pin 1: L+ and Pin 3: L-),
the Online value of the corresponding port is changed to 1.
• 0x01 (1): Short circuit occurred on Pin 1 and 3

Sensor supply short circuit

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 12
(SENSOR_SUPPLY_SHORTCIRCUIT_8CH) » IO Sensor supply short circuit (8 Ch).

2. Check the Online value in the Editor Window.
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6.5. MODULE_STATUS
The Online value shows the status of the supply voltage.
• When the Sensor Power is lower than 18 VDC, the online value of US low is changed to 1.
• When the Actuator Power is lower than 18 VDC, the online value of UA low is changed to 1.
• When the Actuator Power is lower than 10 VDC, the online value of no UA is changed to 1.

Module Status

1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 13 (MODULE_STATUS)
» Module Status.

2. Check the Online value in the Editor Window.
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6.6. OUTPUT_PIN4_8CH
You can control the output on each I/O port.
For PNP model of ADIO-EC,
• 0x00 (0): Output signal of Pin 4 is Low
• 0x01 (1): Output signal of Pin 4 is High

Output Pin 4

1. Select the Solution Explorer » Box 1 (ADIO-EC) » IO-Link DeviceState Inputs to monitor the port
status. The figure below shows the Port in std dig out status since the Online value is 0x_2 (2).

2. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 14
(OUTPUT_PIN4_8CH) » Output Pin 4 of Ch (sub-variable).

3. Select the Editor Window » Online Tab.

4. Select the Write  to enter a value.
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7. Process Data Object (PDO)

TwinCAT creates variables for cyclic input and output signals while configuring the slots.
The variables can be found in sub-folders of the created module.
You can check the process data of connected IO-Link device to the I/O port.
In general, you can find the length and information of the process data on the instructions manual of
the IO-Link device.

• TxPDO (← IOL_I_module): Check the input data

• RxPDO (← IOL_O_module): Write the output data

7.1. Before You Begin
• An IO-Link device is connected to the I/O port.

• The IO-Link module (IOL_I/O_x/_xbyte) is assigned to the slot (IO-Link Ch.0 to Ch.7) of the
corresponding port.

• Check that the Online value of the status of IO-Link Port X is 3. (3: Port in communication OP)
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7.2. Check the TxPDO
1. Double-click the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 1 (IOL_I/O_x/_xbyte) »

TxPDO.

2. You can see the transferred process data via the Online value in the Editor Window.
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7.3. Write the RxPDO
1. Select the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 1 (IOL_I/O_x/_xbyte) »

selection » output byte 0, 1…

2. Select the Editor Window » Online Tab.

3. Select Write  to enter a value.

4. Select the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 1 (IOL_I/O_x/_xbyte) »
selection. You can see that the output data has changed via the Online value in the Editor Window.

7.3. Write the RxPDO 　 49
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8. Access ISDU Parameters

8.1. CoE-Online Tab
If the EtherCAT Slave supports the CAN application protocol over EtherCAT (CoE) protocol, the CoE-
Online tab is displayed. In this tab, you can check the object list of the slave device and change the
value of the object.

The related object list: refer to  11, Object List.

Index

Index and Subindex of the object

The structure of index

• The structure of Index is Index:Subindex, and the value is displayed in
hexadecimal format.
• In the figure above, the index is displayed as 2002:0, but it consists of Index:
2002 and Subindex: 0.
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Name

Name of the object

Flags

RW: The object can be read, and data can be written to the object (read/write).
RO: The object can be read, but no data can be written to the object (read only).
P: Identify the object as a process data object (PDO).
M: Mandatory, element or attribute must exist.

Value

Value of the object

52 　 Autonics | ADIO-EC (TwinCAT 3 Guide)



8.2. Read and Write the Parameters
To access the ISDU parameters of the IO-Link device is available with the object 0x4000 (IO-Link Service
Data Ch. X) in the TwinCAT 3. You can read and write parameters by entering values in the request data
below.

The related object list: refer to  11.5, “IO-Link Service Data Ch. x”.

Read

• Request data: Index, Subindex

• Response data: Length, Data

Write

• Request data: Index, Subindex, Length, Data

• Response data: None

IO-Link Service Data

• Control
0x00: No action
0x02: Write
0x03: Read

• Status
0x00: No activity
0x01: Busy
0x02: Success
0x04: Error
0xFF: Failure

8.3. Before You Begin
• An IO-Link device is connected to the I/O port.

• The IO-Link module (IOL_I/O_x/_xbyte) is assigned to the slot (IO-Link Ch.0 to Ch.7) of the
corresponding port.

• Check that the Online value of the status of IO-Link Port X is 3. (3: Port in communication OP)

• You can check the index of the connected IO-Link device.

• The checkbox of CoE-Online » Auto Update is checked.
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8.4. Read the Parameter

The IO-Link device is connected to port 0.

1. In the CoE-Online tab, select the IO-Link Service Data of the port where the IO-Link device is
connected.

2. Firstly enter the Index or Subindex. The value of 24 was entered in the value field of Index.

◦ Index: 24 (Application specific tag for the IO-Link device)

3. Enter the 0x03 (3), the value of the Control object, to execute Read.

4. Check the value of the Status object. The value is successfully read since the value of 0x02 (Success)
is displayed.

5. Check the values of the Length and Data objects.
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8.5. Write the Parameter

The IO-Link device is connected to port 0.

1. Firstly enter the Index or Subindex. The value of 24 was entered in the value field of Index.

◦ Index: 24 (Application specific tag for the IO-Link device)

2. Enter the values of the Length and Data objects. The following values have been entered in the figure
below.

◦ Length: 3 (The data size of value to be written)

◦ Data: 55 55 55 (Binary)

3. Enter the 0x02 (2), the value of the Control object, to execute Write.

4. Check the value of the Status object. The value is successfully written since the value of 0x02
(Success) is displayed.
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8.6. Check the Changed Parameter
Read-out again to check whether the parameter is successfully written.

1. Enter the 0x03 (3), the value of the Control object, to execute Read.

2. Check the value of the Status object. Read is in progress since the value of 0x01 (Busy) is displayed.

3. Check the value of the Status object again. The value is successfully read since the value of 0x02
(Success) is displayed.

4. Check the value of the Data object. You can see the “55 55 55”, the data to be written, is successfully
reflected.
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9. Startup Tab

If the EtherCAT Slave has a mailbox and supports the CAN application protocol over EtherCAT (CoE) or
Servo Drive over EtherCAT (SoE) protocol, the Startup tab is displayed. The values are transmitted to
the EtherCAT Slave in the order displayed in the Startup tab when initially connecting the EtherCAT
communication. You can also add or change the order of the Startup list.

Transition

It can be set the transition from Pre-Operational to Safe-Operational (PS) or from Safe-Operational
to Operational (SO) status. If the value of Transition is closed with "< >" (e.g., <PS>), the data cannot
be changed or deleted.

9. Startup Tab 　 57



EtherCAT communication status (EtherCAT State Machine)
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9.1. Supported Functions on the Startup
The startup tab supports the following functions.

• Input Filter

• Safe state

• Validation

• Data storage

9.2. Input Filter
The processing time of the digital input signal can be set via this function. The digital input filtering
time suppresses unwanted input signal changes or eliminates noise from input signals to prevent a
data distortion or chattering. It can also be used as ON Delay/OFF Delay depending on the selected
filter time.
The prerequisite condition for this function is that the operation mode of Pin 4 is the standard input.

The related object list: refer to  11.3, “Additional IO-Link Configuration Data (Pin 4) Ch. X”.

9.2.1. Before You Begin
• A device is connected to the I/O port.

• The STD_IN_1bit module is assigned to the corresponding port.

• Check that the Online value of Status of IO-Link Port X is 1. (1: Port in std dig in)
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9.2.2. Select Input Filtering Time

The device is connected to port 1.

1. Firstly check the Index of the port number and double-click the Set Input Filter.
The current value of the Input Filter is set to 3 (1 ms, factory settings).
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2. Let’s select the value of the Input Filter to 11 (256 ms).
① Enter the binary value directly in the field of Data (hexbin).
② Select Input Filter and then enter a value in decimal or hexadecimal format in the Set Value Dialog
window.

3. The value of Input Filter is set to 11.

4. Select  (Restart TwinCAT) or  (Reload Device).

9.2. Input Filter 　 61



5. Select the Solution Explorer » Device » Box 1 (ADIO-EC) » Module 2 (selection) » Digital Input Bit
to check the Online tab of the Editor Window. You can see the waveforms depending on the input
filtering time.

Input Filter: 3 Input Filter: 11
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9.3. Safe State
Define the behaviour of output on each I/O port when the communication connection is interrupted
between the EtherCAT Master and the ADIO-EC.
The prerequisite condition for this function is that the operation mode of Pin 4 is the standard output.

The related object list: refer to  11.3, “Additional IO-Link Configuration Data (Pin 4) Ch. X”.

Safe state

In case of the output behaviour for the PNP model of ADIO-EC under the disconnection of EtherCAT
communication,

• 0x00: 0

◦ Output of Pin 4: Switch to Low

◦ No. 0 of the I/O port indicator: OFF

• 0x01: 1

◦ Output of Pin 4: Switch to High

◦ No. 0 of I/O port indicator: ON (yellow LED)

• 0x02: 2, last state

◦ Output of Pin 4: Keep the previous state

◦ No. 0 of I/O port indicator: keep the previous state

9.3.1. Before You Begin
• A device is connected to the I/O port.

• The STD_OUT_1bit module is assigned to the corresponding port.

• Check that the Online value of Status of IO-Link Port X is 2. (2: Port in std dig out)
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9.3.2. Setting Safe State

The device is connected to port 0.

1. Firstly check the Index of the port number and double-click Set Safe State.

2. Let’s set the Safe state value to 0x01 (1).
① Enter the binary value directly in the field of Data (hexbin).
② Select Safe state, and then enter a value in decimal or hexadecimal format in the Set Value Dialog
window.
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3. The value of Safe state is set to 1.

4. Select  (Restart TwinCAT) or  (Reload Device).

5. If the EtherCAT communication is interrupted, yellow LED on the no. 0 I/O port indicator of the port 0
lights up and the output state of Pin 4 is switched to High.
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9.4. Validation
When the power is supplied, compare and verify a connected IO-Link device with a IO-Link device
information (Vendor ID, Device ID) stored in the IO-Link Master.
The prerequisite condition for this function is that the operation mode of Pin 4 is the IO-Link.

The related object list: refer to
11.3, “Additional IO-Link Configuration Data (Pin 4) Ch. X”,
11.7, “IO-Link Information Data Ch. x”,
11.6, “IO-Link Configuration Data Ch. x”.

Validation Type

• 0x00 (0, No validation): Disabled

• 0x01 (1, TYPE COMP): Compare Vendor ID and Device ID and then start the IO-Link communication
only if they are matched.

9.4.1. Before You Begin
• An IO-Link device is connected to the I/O port.

• The IO-Link module (IOL_I/O_x/_xbyte) is assigned to the slot (IO-Link Ch.0 to Ch.7) of the
corresponding port.

• Check that the Online value of Status of IO-Link Port X is 3. (3: Port in communication OP)
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9.4.2. Setting Validation Type

The IO-Link device is connected to port 0.

1. Check the Device Id and Vendor Id in the CoE-Online tab.

2. Open the Startup tab and check the Index of the port number.

9.4. Validation 　 67



3. Apply the information checked in the CoE-Online tab to Set Device Id and Set Vendor Id.
Set the value of Set Validation Type to 1 (TYPE COMP).

4. Select  (Restart TwinCAT) or  (Reload Device).

5. If an IO-Link device with a different Device Id or Vendor Id is connected to port 0,
① 48 (invalid DID) or 64 (invalid VID) is displayed in the Online field of Status of IO-Link Port 0.

② Red LED blinks on the no. 0 I/O port indicator of the port 0.
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9.5. Data Storage
The whole parameters of IO-Link device are stored/uploaded in the IO-Link Master (BACKUP),
or apply/download last updated parameters to the compatible IO-Link device (RESTORE).
The prerequisite condition for this function is that Validation Type is set to 1 (TYPE COMP).

The related object list: refer to
11.3, “Additional IO-Link Configuration Data (Pin 4) Ch. X”,
11.5, “IO-Link Service Data Ch. x”,
11.7, “IO-Link Information Data Ch. x”,
11.6, “IO-Link Configuration Data Ch. x”.

Data storage

• 0x00 (0): DS DISABLE

• 0x01 (1): BACKUP/RESTORE

• 0x02 (2): RESTORE

9.5.1. Before You Begin
• An IO-Link device is connected to the I/O port.

• The IO-Link module (IOL_I/O_x/_xbyte) is assigned to the slot (IO-Link Ch.0 to Ch.7) of the
corresponding port.

• Check that the Online value of Status of IO-Link Port X is 3. (3: Port in communication OP)

• You can check the Index of the connected IO-Link device.

• The checkbox of CoE-Online » Auto Update is checked.
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9.5.2. Setting Data Storage

Port 0: Used as the port for the data storage
Port 1: Accessing the parameters, refer to  8, Access ISDU Parameters.

1. Check the information of the IO-Link device connected to port 1. Read parameters in the CoE-Online
tab. In the figure below, the data is written as "11 22 33" for convenience.

2. Check the data is properly written by read-out the parameter.
You can see that the write has been successfully applied in port 1.
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3. Open the Startup tab and check the index of port 0, and configure as below.

◦ Set Device Id, Set Vendor Id: The same value as the IO-Link device of port 1

◦ Set Validation Type: 1

◦ Set Data Storage: 1

4. Select  (Restart TwinCAT) or  (Reload Device).

5. Disconnect the IO-Link device connected to port 1 for BACKUP.

6. Connect the previously disconnected IO-Link device to port 0 for more than 3 seconds.

7. Connect the IO-Link device to port 1 again.
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8. Change the data to check BACKUP/RESTORE.
Write parameters in the CoE-Online tab. The changed value of data is "55 66 77".

9. Check the data by read-out the parameter. The write has been successfully applied.
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10. Disconnect the IO-Link device connected to port 1 for RESTORE.

11. Connect the previously disconnected IO-Link device to port 0 for more than 3 seconds.

12. Connect the IO-Link device to port 1 again.

13. Read parameters in the CoE-Online tab.
RESTORE is successfully completed since the data is "11 22 33".

Forced parameter backup of IO-Link device
1. Set Data storage to 1 (BACKUP/RESTORE).
2. Write 0x05 to Index 0x02 of the IO-Link device.

Clear data storage
Set as Validation Type: 1 and Data Storage: 0.
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10. Replace the IO-Link Device

1. The parameter set of the new IO-Link device is factory settings.

2. The new IO-Link device has to support the IO-Link version 1.1 or higher.

1. Disconnect the IO-Link device from the IO-Link Master.

2. Connect the new IO-Link device to the same port.

3. Apply the parameter values stored in the memory of the IO-Link Master to the connected IO-Link
device. For detailed information, refer to  9.5, “Data Storage”.

10. Replace the IO-Link Device 　 75
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11. Object List

• The n in Index represents an I/O port. (n = 0 → Port 0, N = 1 → Port 1)

• RW: Read and Write

• RO: Read Only

11.1. Process Data (Pin 2) Ch. X
Index Subindex Name Flags (Data type) Value

0x20n0
(n: 0 to 7)

0x01 Input Pin 2 RO (BOOLEAN)

11.2. Process Data (Pin 4) Ch. X
Index Subindex Name Flags (Data type) Value

0x20n1
(n: 0 to 7)

0x01 Actor short circuit Pin 4 RO (BOOLEAN)

0x02 Sensor supply short circuit RO (BOOLEAN)

0x03 Input Pin 4 RO (BOOLEAN)

0x04 Output Pin 4 RO (BOOLEAN)
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11.3. Additional IO-Link Configuration Data (Pin 4) Ch. X
Index Subindex Name Flags (Data type) Value

0x20n2
(n: 0 to 7)

0x01 Safe State RW (UINT8) • 0x00: 0
• 0x01: 1
• 0x02: Last state

0x02 Validation Type RW (UINT8) • 0: No validation
• 1: Compatible
(Vendor ID + Device ID)

0x03 Data Storage RW (UINT8) • 0: DS DISABLE
• 1: BACKUP/RESTORE
• 2: RESTORE

0x04 Input Filter RW (UINT8) • 0: No filter
• 1: 250 us
• 2: 500 us
• 3: 1 ms (default)
• 4: 2 ms
• 5: 4 ms
• 6: 8 ms
• 7: 16 ms
• 8: 32 ms
• 9: 64 ms
• 10: 128 ms
• 11: 256 ms

11.4. Module Status Data
Index Subindex Name Flags (Data type) Value

0x2A02 0x01 US low RO (BOOLEAN)

0x02 UA low RO (BOOLEAN)

0x03 no UA RO (BOOLEAN)
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11.5. IO-Link Service Data Ch. x
Index Subindex Name Flags (Data type) Value

0x40n0
(n: 0 to 7)

0x01 Control RW (UINT8) • 0: No control action
• 2: Write
• 3: Read

0x02 Status RO (UINT8) • 0: No activity
• 1: Busy
• 2: Success
• 4: Error
• 0xFF: Failure

0x03 Index RW (UINT16)

0x04 Subindex RW (UINT8)

0x05 Length RW (UINT8)

0x06 Data RW (UINT232)

0x07 Error Code RO (UINT16)

11.6. IO-Link Configuration Data Ch. x
Index Subindex Name Flags (Data type) Value

0x80n0
(n: 0 to 7)

0x04 Device Id RW (UINT32)

0x05 Vendor Id RW (UINT32)

0x20 IO-Link Revision RW (UINT8)

0x21 Frame Capability RW (UINT8)

0x22 Cycle Time RW (UINT8)

0x24 Process Data In Length RW (UINT8)

0x25 Process Data Out Length RW (UINT8)

0x28 Master Control RW (UINT16) • 1: Standard Input
• 2: Standard Output
• 3: IO-Link Mode
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11.7. IO-Link Information Data Ch. x
Index Subindex Name Flags (Data type) Value

0x90n0
(n: 0 to 7)

0x04 Device Id RO (UINT32)

0x05 Vendor Id RO (UINT32)

0x20 IO-Link Revision RO (UINT8)

0x21 Frame Capability RO (UINT8)

0x22 Cycle Time RO (UINT8)

0x24 Process Data In Length RO (UINT8)

0x25 Process Data Out Length RO (UINT8)

11.8. IO-Link Diagnosis Data Ch. x
Index Subindex Name Flags (Data type) Value

0xA0n0
(n: 0 to 7)

0x01 IO-Link State RO (UINT8) • Refer to the
mapping.

0x02 Lost Frames RO (UINT8) Number of lost
frames

11.9. IO-Link Status Data Ch. x
Index Subindex Name Flags (Data type) Value

0xF100 0x01 Status of IO-Link Port 1 RO (UINT8) • Refer to the
mapping.0x02 Status of IO-Link Port 2 RO (UINT8)

0x03 Status of IO-Link Port 3 RO (UINT8)

0x04 Status of IO-Link Port 4 RO (UINT8)

0x05 Status of IO-Link Port 5 RO (UINT8)

0x06 Status of IO-Link Port 6 RO (UINT8)

0x07 Status of IO-Link Port 7 RO (UINT8)

0x08 Status of IO-Link Port 8 RO (UINT8)
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• Mapping: Status of IO-Link Port

Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

Error code Port status

• The Status of IO-Link mode

Port status Error code

Hex Dec Description Hex Dec Description

0x_0 0 port disabled 0x1_ 16 watchdog detected

0x_1 1 port in std dig in 0x2_ 32 initial Error

0x_2 2 port in std dig out 0x3_ 48 invalid Device ID

0x_3 3 port in communication OP 0x4_ 64 invalid Vendor ID

0x_4 4 port in communication
COMSTOP

0x5_ 80 invalid IO-Link
version

0x6_ 96 invalid Frame
Capability

0x7_ 112 invalid Cycle Time

0x8_ 128 invalid PD in length

0x9_ 144 invalid PD out length

0xA_ 160 no device detected
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